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Assignment 5 — Unit 3
Web Page Creation Report

_ _ In order to create my web pages, | used a program
Mﬁ%ﬂmm called FrontPage Express. This allowed me to create
web pages without learning the language they are
written in, HTML.
To start with, | created a new directory for the website to go in to. | did this by clicking on
File>New>Folder. | then renamed the folder just created to Computerstore.
Into that folder, | created five more folders, and renamed them Images, INP, -
OUT, MPU and STO.
ﬁ ﬁ ﬁ, ﬁ, ﬁ, These were for the four
different  sections of
products and for the images.

_ompukterstar

Images

My next task was to create the index page. In FrontPage Express, | created a new page by clicking
on File>New>Normal Page. | then right-clicked on the page and selected page properties. | could
then change the background colour. After | found that none of the preset colours were suitable, |
created a custom colour by entering different amounts of Hue:ﬁ Hed:'ﬁ
Red, Blue, and Green until | found a colour that | liked. | - sat[138 Gieen |13
then added this to the custom colours list so | could use it s e

Color)S olid . I . I
on the other pages. Lur 114 Blue: |217
Add to Custom Colors I
Background; I- Crzharm j Hyperlink: I- Black j
Test I- Defaul j Wlkhied Hpalis I- Black j | then set all of the text and

hyperlink colours to black so
Active Hyperink: |l Black ¥ that all the text on the page

would the same colour. Whilst | was in

. . Title: c Id Oriline Catal -H P
page properties, | added the page title that ' |Eompuword Oriine Catalogue - Home Page

would be shown at the top of the browser by typing the title | wanted into the title box. With
the properties set how | wanted, | could lay out the page.
| wanted to add a table on the page, to contain the

Size
= |4—__, hyperlinks to the other pages. To do this, | clicked on
oE: = T — . !
able>Insert Table, and [ltees— | [Mmnmumwidh
. igrment: Center ™ Specitywidth: [100
Columr: 1] = entered the size of table ’:'gd - th = - rl_ »
| wanted, as shown to = & in Percent
Cell Padding: |1 _Ij
the left. | then formatted | . !
i pacing: _vl
Compuworld .1 the table by right clicking - —
. [ LLstom Dackgroun:
DII].iIlE Cﬂtﬂlﬂglle on the OUtIIne) and [T Use Background Image
Selectlng Table I Ercise. .. | Properlies..l
Pl‘oper‘ties. I added a Background Color: | [l D efault vl
|Majn Processing Um't| border of size 10, aligned .. ...
. Border: m
Tnput Devices the table to the centre, | Hawy
= and coloured the border | listtBade: [EE Hawy -
| Output Devices navy, as shown to the | ova«soc [EITEEENNN-]

Storage Devices right. | clicked OK and
went back to the home page. | added the section names into
the table, and added a two-line title. Using the defaults, the page
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looked like the image to shown above. | then formatted all of the text into a different font,
Franklin Gothic Heavy. | then changed the size of the first line of the title to the largest, size 7,
and underlined it.

My newly formatted homepage now looked like this. | saved the
compuworld file into the main directory as index.htm. In order to create the
Online Catalogue index pages for the sub-directories, | used the homepage as a

template. For each index page, all | would need to do was to

’m‘ change the page title in page properties, change the title on the

= page, change the text in the table, delete some of the cells of the

Input Devices table and alter the size of the border. | decided to do this as it
Output Devices was a lot quicker and easier that creating each page from scratch.

Storage Devices | did this for all four-sub directory indexes, changing the hyperlink
names for those in each sub directory. These were then saved,
with appropriate page titles and file names into the main

directory. The hyperlinks were not put into working order vet as | had not yet created the other
pages.

| then had to create the pages in the sub-directories containing the information. In order to save
time, | created a template based on the index page in FrontPage Express. It had the same sized
title, but contained two tables. These were four columns wide and six rows high, but contained
headings in the top row of Item, Description, Price, and Picture. This was then saved into each
sub-directory several times, with different names corresponding to the information they would
hold. With that complete, | now had to get my images for use in the web page.

To do this, | went onto the website of PC World, where | browsed through the pages selecting
images for the types of products | needed and saved them with approprlate filenames into the
Images sub-directory. | also recorded the information about each of the e et
products so that | could use it on my web pages. | could now input this e
data into my web pages. | opened up each web page from the

e

Copy. Shorkeut

subdirectories, and entered the data into it. | inserted the image into the s he var
picture column by clicking on Insert>Image>Browse and double-clicking 7~ \ "=

Froperties

£0.09

on the image | wanted from the Images sub-directory. | entered the
prices in the prices column, entered the specification in the description
column, and entered the

Compuworld . product name in the item
Modem,/Network column. | also added the page title in the page
Modem _| properties box, entered
A madom allows yoir to conect to the internot through your phone iine. the page title under the |De5cription
Item [pescription [Price |[picture Compuworld banner,

entered the sub-title |Y6kSpeed ]
under that, and entered a |V.92 Standard .|
description of what that |Internal .|

genre of product does. | (PCI Interface
also deleted any unused cells from the tables. | did this for all of the pages

PCLINE 56K Internal|(56k Speed .| £25.99|
V.92 Standard _| s

Internal .|

PCl Interface

located in the sub-directory based on the template. An example of one of
the pages is shown above.

Now that all of the pages were completed, |
could set-up my hyperlinks. To do this, |
opened up all of my index pages from the main
directory. On the sub-indexes, | selected the
cells of the table containing the hyperlinks and

& Split into Columns l_l_

 5plit into Fiows

Cancel

Murnber of Calumns: I _Ij

Help

LLIB
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then clicked on Table>Split Cells. | then selected Split into Columns, and two columns and
clicked OK. . This left me with the text in the left hand column, and an empty column to the
right. Into this empty column, | inserted an image from the Images folder that was related to the
title in the left hand column, for example, a modem for the Modem/Network page and a printer
for the printers’ page. | repeated this for all of the sub-index pages. | could now turn the text and
pictures into hyperlinks. To do this, | selected the text and images in each row separately, and
clicked on the hyperlink button on the toolbar, which looks like a small globe. | then typed in the
page location to the page that | wanted to link to, as shown below. | did this for each image and
piece of text in table of the sub-index pages, as well as the text in the table of the index page. The

sub-index now looked like this.
Hyperlink Type: |[other] Vl

LRL:
CPU/Motherboard ~ Al
Modem/Network §E
“ -j,.:::—"':_’v.;,
RAM EEE) | With the hyperlinks in place, the site was nearly complete and was
| completely navigable. | decided to add sound to my site, to make it

more interesting, 51§ {all 59%0 of CTY¥-IIF.wav Completed =0 x|
as it can annoy people, | decided to only put it on
the home page. The sound | planned was a short
musical jingle, followed by instructions on how to
use the site. The jingle | decided to use was short,

and | downloaded it from a website. After E.s.nr.n:t:: :r:e.I:f:.;?l sle.cl[als.lal;al:f.?;_; KB copisd
downloading it to my directory, | set about = Downloadte:  MACTVIF.wav

recording the instructions. To do this, | required a =~ ™™= 116K
microphone, which luckily was attached to the
computer | was working on. | created a new wave T e |
sound, by clicking on File>New>Wave Sound in My
) Documents. | then selected the file produced, clicked
i New Wave Sound - Soul =10IXl onee again on File, and then clicked on Record. This

el [Edt Effects  Help launched Sound Recorder, the program | was going

Pasitiar: Lt to use to record my voice. After checking the sound
795 can .50 sac. was activated through Volume Control, accessible via
|
_

©

[~ Close thiz dislog box when download completes

the small speaker icon in the System Tray, | could
record my message. | clicked on the red Record

<4 | »» || m | @ | button and spoke into the microphone, pressing the
square stop button when | was finished. | repeated

this several times until | had the introductory message how | wanted it. After trimming the file, by
moving to an appropriate point and clicking on Edit>Delete before Current Position or Delete
after Current Position, | could insert the jingle into the message. | moved to the start of the file,
then clicked on Edit>Insert File. | double clicked on the file | downloaded from the Internet
previously, and then clicked on OK. The jingle was now inserted at the start of the file, so | could
save it, as | did to the main directory of the website as
jingle.wav. This was then inserted as a background sound in
the home page. To do this, | right-clicked on the page and then on Page Properties. | typed the
jingle’s filename into the background sound box, made sure that the loop box read | and then
clicked on OK. The jingle was inserted to automatically play each time the home page was

Insett File, .,
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Background Sound loaded. The web site was now

Location:  [iingle. wav Biaras.. I completely finished.
Loop: I'I 3: ™ Farever

All through the creation of my web pages, | kept a backup copy of the files on a floppy disk. | did
this so that my work would be safe it the main copy on the computer system went down. The
standard way of backing up is to save each file separately
with the suffix _bak, however, | could not do this for the
web pages as there were far too many files, and if the files
were renamed, the hyperlinks between the pages would <« Back - = - | CyFolders  (#His
cease to function. Instead, | dragged and dropped the
Computerstore directory, which contained all of the files

and sub-directories, to the k
floppy drive, and then added M
J File Edit View Favotibh then added the suffix on|y to Zomputerskor

| 4Back ~ = - [i] | this directory. To do this, | :
opened up two My Computer

! 314 Floppy

File Edit Yiew Faworibes Tools  Help

ﬁ, windows; into one, | opened M/My GNVQ/Ass5, the directory in
Computorst which the Computerstore directory was located, and in the other, |
R opened up the floppy drive. | left-clicked and held on the

Computerstore directory, and dragged it over to the floppy window. It
took a while to copy all of the files, but when this was done, | renamed the folder by clicking on
File>Rename, and then adding the suffix. | did this at the end of every session of work, after
deleting the previous version of the Computerstore directory.

Although FrontPage Express is very good at making web pages, it does not include a spell
checking facility. This would have made the creation of the web pages much easier as | would

ey - Microsot Word have been able to check that the text was
File Edit Wiew Insert Format Tools Table Window Help .
ZHE SR o o . correct as | went along. Instead, | had to wait
Nl (webi < FralinGahcres - %+ B 7 O -a-. until | had completed all of the pages. When
E-w1‘|-2-wz-\-4‘|‘5-\-s‘|‘7-\-8-\-3‘\‘m-\-u‘\‘12-|-13-|-14‘\‘ls‘l-ls‘\‘17‘ I wanted to Check the Spelllng |n the Pages, I
first opened the page in Microsoft Internet
Compuworld P page. )
T Explorer. Upon loading, | clicked
eyboar ouse . . o | -
. upon the Microsoft Word logo just
Keyboards .
Keyhoards are used in input alphanumerical data into com puters. beneath the addreSS bar' ThlS bUtton opened
ey aremecdation il csniitan the HTML page in Microsoft Word. As
”Item HDescription Price |Picture Word has Spe|| Checking facilities, it could be
PCLINE Keyhoard Blue £6.25 || e, 1 H
o ol M used for checking the text for 'mlstakes.
Multimedia Kevs When the page was loaded, | clicked on
Tools Table ‘Window Help TooIs>SpeII|ng and 2=
i v p— F7 Grammar which initiated  tietisicinary: :|
2peiing and arammar. .. i/ - Resume I
= the spell checker. When =
Word Count. .. P com pllworld Tgnore Al
any unknown words
. - Mavhnanaud /Manen LI Add
were found, they are shown in the top panel, as shown  suseic-
to the right, and a list of alternatives is shown below. | AL o |
noted down [ oo |
the mistakes ;
Dictionary language: IEnghsh [(IN %] j
on paper SO ¥ Check grammar
@ The spelling and grammar check is complete. that | could 1= Dptians... s | concel |
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alter the text in FrontPage Express. This was repeated for all of the web pages. As Word had the
ability to save a document as a HTML file, it would have been easier to check the spellings,
correct them and save them as a web page from Word. | chose not to do this, because Word,
although it can save documents as a HTML file that is read by web browsers, it is actually saved as
AML (Extended Markup Language) which neither Front Page Express or | could understand.

In order to ensure that the data in the pages was correct, | directly copied and pasted it from the
PC World website. This would make it virtually impossible for the data to change and become
incorrect. This method was not perfect, in that it relied on the PC World to be correct.



